Increased latency between Guam and United States due to submarine cable cut
Resolved
Jul 22 at 02:53pm AEST
Subsea cable repairs have been completed and direct connectivity between Guam and the United States has been restored. Latencies for traffic on this route have returned to normal.
Affected services
Updated
Jul 08 at 03:31am AEST
The cable provider has delayed the restoration of the cable. There is no current ETR.
Affected services
Updated
Jun 27 at 11:13am AEST
Our subsea cable provider has provided an estimated time of restoration of July 4th. Traffic remains rerouted.
Affected services
Created
May 19 at 12:51am AEST
People connecting from the United States mainland will have higher latency connecting to Guam due to a submarine cable cut. Traffic has been rerouted.
The sea cable provider has not yet provided an estimated time of restoration and we will provide updates when we have more information.
Affected services