Back to overview
Degraded
Increased latency between Guam and Singapore due to submarine cable cut
May 27 at 01:03pm AEST
Resolved
Jun 13 at 01:50pm AEST
Submarine cable repairs are complete and latency between Guam and Singapore is back to normal.
Affected services
Updated
May 29 at 03:15pm AEST
The Guam ↔ Singapore subsea cable now has an estimated time of restoration of 21st June — subject to permit, technical and weather conditions.
Affected services
Created
May 27 at 01:03pm AEST
People connecting from Singapore and surrounding areas will have higher latency connecting to Guam due to a submarine cable cut. Our submarine cable provider estimates repairs will be completed by the end of June.
While we investigate ways to improve latency, we're rerouting affected traffic via Tokyo or Sydney.
Affected services