Back to overview
Degraded

Increased latency between Guam and Singapore due to an extended maintenace event

May 03 at 08:53am AEST

Resolved
May 04 at 12:07pm AEST

The cable provider has completed repairs and connectivity is back working as expected.

Created
May 03 at 08:53am AEST

We are experiencing higher than normal latency between Guam and Singapore at the moment due to a cable provider's maintenance that has gone beyond the scheduled window. The outage is ongoing and there is no ETTR currently.

[Start Date & Time]
2023/05/03 16:00 UTC