Back to overview
Degraded
Increased latency between Guam and USA/Europe due to a cable cut
Aug 04 at 03:02am AEST
Resolved
Aug 14 at 12:16pm AEST
Repairs complete; USA ↔ Guam latency has returned to normal.
Affected services
Created
Aug 04 at 03:02am AEST
A provider of our main subsea cable between Los Angeles and Guam will be performing a service impacting repair event between 2023/08/03 20:00 UTC and 2023/08/12. Users will notice increased latency between Guam and the USA/Europe during this repair event.
Affected services